{"error":0,"message":null,"data":{"name":"Menu Cart for WooCommerce","plugin":"woocommerce-menu-bar-cart","link":"https:\/\/wordpress.org\/plugins\/woocommerce-menu-bar-cart\/","latest":"1792402320","closed":0,"closed_reason":null,"closed_date":null,"vulnerability":[{"uuid":"e23e087e212dd0f2b3b916f812b6be34a51039235d8bc180efe11755ef37f2b0","name":"Menu Cart for WooCommerce [woocommerce-menu-bar-cart] < 2.12.0","description":null,"operator":{"min_version":null,"min_operator":null,"max_version":"2.12.0","max_operator":"lt","unfixed":"0","closed":"0"},"source":[{"id":"a29e30b7f291ef425db21c107fa671ede0cf99d0","name":"WordPress WooCommerce Menu Cart plugin <= 2.11.0 - Reflected Cross-Site Scripting (XSS) vulnerability","link":"https:\/\/patchstack.com\/database\/wordpress\/plugin\/woocommerce-menu-bar-cart\/vulnerability\/wordpress-woocommerce-menu-cart-plugin-2-11-0-reflected-cross-site-scripting-xss-vulnerability","description":"Reflected Cross-Site Scripting (XSS) vulnerability discovered by WPScanTeam in WordPress WooCommerce Menu Cart plugin (versions <= 2.11.0).\nUpdate the WordPress WooCommerce Menu Cart plugin to the latest available version (at least 2.12.0).","date":"2022-06-07"}],"impact":[]},{"uuid":"599cd724ce33b247851a9b672caff55928e7138100743b946da7df3719e3a9e8","name":"Menu Cart for WooCommerce [woocommerce-menu-bar-cart] < 2.12.0","description":null,"operator":{"min_version":null,"min_operator":null,"max_version":"2.12.0","max_operator":"lt","unfixed":"0","closed":"0"},"source":[{"id":"5361500d3e1c2817824a8556a6d848598ca04a4c","name":"WooCommerce Menu Cart <= 2.11.0 - Reflected Cross-Site Scripting","link":"https:\/\/www.wordfence.com\/threat-intel\/vulnerabilities\/wordpress-plugins\/woocommerce-menu-bar-cart\/woocommerce-menu-cart-2110-reflected-cross-site-scripting","description":"The WooCommerce Menu Cart plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in versions up to, and including, 2.11.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","date":"2022-06-07"}],"impact":[]},{"uuid":"9b297eb6aa419bee0eea446f98a09a5636522d46e11b9092385874f9f2b479c8","name":"Menu Cart for WooCommerce [woocommerce-menu-bar-cart] < 2.12.0","description":null,"operator":{"min_version":null,"min_operator":null,"max_version":"2.12.0","max_operator":"lt","unfixed":"0","closed":"0"},"source":[{"id":"963ccc1e-ab38-4bc8-86b7-3472c84a6b74","name":"WooCommerce Menu Cart &lt; 2.12.0 - Reflected Cross-Site Scripting","link":"https:\/\/wpscan.com\/vulnerability\/963ccc1e-ab38-4bc8-86b7-3472c84a6b74","description":"The plugin does not escape some URLs before outputting them back in attributes, leading to Reflected Cross-Site Scripting","date":null}],"impact":[]},{"uuid":"cd923070d8aadd8323db66a5c514857002bbe39ec439594fffa72cb5276ee8aa","name":"Menu Cart for WooCommerce [woocommerce-menu-bar-cart] < 3.2.1","description":null,"operator":{"min_version":null,"min_operator":null,"max_version":"3.2.1","max_operator":"lt","unfixed":"0","closed":"0"},"source":[{"id":"CVE-2026-105972","name":"CVE-2026-105972","link":"https:\/\/www.cve.org\/CVERecord?id=CVE-2026-105972","description":"[en] The Menu Cart for WooCommerce WordPress plugin before 3.2.1 does not sanitise and escape cart item variation data before outputting it in its cart slide-out, allowing unauthenticated users to store a Cross-Site Scripting payload that can be delivered to and executed in the session of another user, including a logged-in administrator.","date":"2026-10-28"},{"id":"b4bebdfa17f19a8aa199ddf5cfd89c1170873d40","name":"WordPress WooCommerce Menu Cart Plugin < 3.2.1 is vulnerable to a medium priority Cross Site Scripting (XSS)","link":"https:\/\/patchstack.com\/database\/wordpress\/plugin\/woocommerce-menu-bar-cart\/vulnerability\/wordpress-menu-cart-for-woocommerce-plugin-3-2-1-unauthenticated-stored-xss-vulnerability","description":"<p>WordPress WooCommerce Menu Cart Plugin < 3.2.1 is vulnerable to a medium priority Cross Site Scripting (XSS)<\/p><p>Software: WooCommerce Menu Cart<\/p><p>Fixed in version 3.2.1 <\/p><p>Affected Version < 3.2.1<\/p><p>CVE: CVE-2026-105972<\/p>","date":"2026-10-28"},{"id":"cc0df2cc13b090aca38eaceaf21c33d29bc263af","name":"Menu Cart for WooCommerce < 3.2.1 - Unauthenticated Stored Cross-Site Scripting","link":"https:\/\/www.wordfence.com\/threat-intel\/vulnerabilities\/wordpress-plugins\/woocommerce-menu-bar-cart\/menu-cart-for-woocommerce-321-unauthenticated-stored-cross-site-scripting","description":"The Menu Cart for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to 3.2.1. This is due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","date":"2022-06-07"}],"impact":{"cwe":[{"cwe":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","description":"The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users."}],"ssvc":{"exploitation":"none","automatable":"no","technical_impact":"total","kev":false,"kev_date":null}}}]},"updated":"1793253756"}